Elevated 5xx responses in gcp-us-east4

Incident Report for turbopuffer

Resolved

As of 13:26 UTC the incident has been resolved.
Posted Jul 02, 2025 - 14:05 UTC

Identified

An incident affecting 0.04% of write traffic began at 6:00 UTC. Our team is currently investigating. We recommend utilizing client-side retries to mitigate this issue.
Posted Jul 02, 2025 - 12:31 UTC
This incident affected: API.