partial outage
Incident Report for turbopuffer
Resolved
The issue has been identified and resolved. A node in gcp-us-central1 experienced highly degraded networking between 17:15-17:22 UTC. Our existing network failure handling logic was unable to handle such a major degradation in service. As a result, ~12.5% of query traffic in the region was affected.

We're taking retroactive steps to ensure nodes that encounter these sorts of networking issues are taken out of rotation automatically.
Posted Jul 15, 2024 - 17:22 UTC
Investigating
We are currently investigating this issue.
Posted Jul 15, 2024 - 17:15 UTC
This incident affected: API.